Instalar DraftSight en Ubuntu 64bits

La version beta1 del cad gratuito DraftSight está disponible para instalar en ubuntu mediante un DEB compilado para i386, por esta razón al hacer doble click en el deb no se instala y dice que hay error en la arquitectura. La manera de instalarlo entonces es forzando la arquitectura como se explica en el foto de Ubuntu. Desde la consola hay que poner lo siguiente:

sudo dpkg --force-architecture -i DraftSight.deb

Lo que figura en negrita debe ser la ruta completa al archivo deb (se puede arrastrar el archivo deb y soltarlo en la consola para que escriba la ruta completa)

Una vez hecho esto dio dos nuevos errores porque faltaban las siguientes dependencias:

  • libdirectfb-extra
  • libxcb-render-util0

La solución entonces fue instalarlas con los siguientes códigos en la consola:

  • sudo apt-get install libdirectfb-extra
  • sudo apt-get install libxcb-render-util0

Una vez instaladas las dependencias ya se puede instalar con el primer código que puse al comienzo en color verde. La prueba de la instalación es la imágen al comienzo de este artículo ;)

Por las pocas pruebas que hice veo que es muy fácil de manejar, extremadamente similar a AutoCAD, soporta tipografías TTF , posee varios espacios papel (paper-space) y abre muy bien archivos de Autocad.


Anuncios

21 comentarios sobre “Instalar DraftSight en Ubuntu 64bits

  1. Hola, gracias por postear contenido como éste. Mi problema es que tengo Ubuntu 11.04 de 64 bits, y al tratar de forzar la instalación me aparece el siguiente mensaje:

    juanjose@ubuntucat:~$ sudo dpkg –force-architecture -i DraftSight.deb[sudo] password for juanjose:
    dpkg: aviso: sobreseyendo el problema porque está activa la opción –force:

    la arquitectura del paquete (i386) no corresponde con la del sistema (amd64)
    dpkg: acerca de DraftSight.deb que contiene dassault-systemes-draftsight:i386, problema de predependencia:
    dassault-systemes-draftsight:i386 predepende de libexpat1 (>= 2.0.1-4)
    dpkg: error al procesar DraftSight.deb (–install):
    problema de predependencia – no se instala dassault-systemes-draftsight:i386
    Se encontraron errores al procesar:
    DraftSight.deb

    Y ahí queda, he comprobado que tengo instalada la librería libexpat1, pero en la versión actual (2.0.1-7). ¿qué hacer?

    Me gusta

  2. Hola de nuevo, gracias por responder, de veras que tampoco encontraba una solución. Hasta que di en ubuntuforums con un thread sobre este problema, el procedimiento es:

    Extraer el contenido de DraftSight.deb en una carpeta (por ejemplo:DS)
    Luego copiar las carpetas DS/opt/ y DS/var/ a nuestro directorio /opt y /var respectivamente.
    Luego acceder desde terminal a DS/DEBIAN, y
    sudo ./preinst
    sudo ./postinst

    Esto hará que se aparezca en el dash de Unity, con un ícono al escribir “draf…”; al hacerle clic ya se pude lanzar!
    Hasta ahora me ha funcionado y no he tenido problemas. Aunque en el thread original player107 dice que tiene un problema con las ventanas, que parpadean y por eso no lo puede usar. Como no he tenido ese problema supongo que será porque él no instaló las librerias que indicas más arriba.

    De nuevo gracias por la noticia y espero que esto ayude a aquellos que no les anda forzando la arquitectura con Ubuntu 11.04.

    Me gusta

  3. hola disculpen alguien me puede decir como lo puedo desintalar mediante la terminal, por que en el centro de software lo no lo encuentra para desinstalar saludos

    Me gusta

  4. Hola Siul, para desinstalarlo deberás borrarlo de las carpetas donde lo desinstalaste. Podes hacerlo con la terminal o con “sudo nautilus”

    Me gusta

  5. Hola gente
    yo tenia (tengo) instalado DraftS…. en ubuntu 11.04 64bits y funcionaba medianamente bien. Al actualizar a Ubuntu 11.10 el DraftS… se me cuelga al abrir alguna orden que se vea en una ventana (ej al editar texto, editar layer) y me queda la pantalla gris y debo reiniciar el escritorio grafico o forzar que salga de DraftS…
    Intente desinstalarlo y no me deja hacerlo, pero ahora veo que se hace eliminando carpeta directamente. Voy a probar esto ultimo, pero mientras voy a esperar si a alguien le pasao lo mismo que a mi y si pudo solucionarlo sin desinstalarlo.
    Desde ya muchas gracias
    exitos totales
    negrodario

    Me gusta

  6. Darío, a mi no me pasa lo mismo porque lo uso poco y además instalé ubuntu 11.10 desde cero, es decir formateando s instalando todos los programas de nuevo. Proba de borrarlo y reinstalarlo a ver como te va. Saludos

    Me gusta

  7. hola soy nueva, la verdad no se muy bien como instalar el programa me aparece un error que dice E: No se ha podido localizar el paquete libxcb-render-util0
    pero he hecho todo como lo explican, que puedo hacer?

    Me gusta

  8. instale la version de 32

    sudo apt-get install libdirectfb-extra

    libxcb-render-util0 lo encontre en esta direccion ya que fue lo que me marcaba que no encontraba la libreria

    https://launchpad.net/ubuntu/oneiric/+package/libxcb-render-util0

    al darle doble clic al archivo (ubuntu/oneiric/i386/libxcb-render-util0/0.3.6-1build1) llama al centro de softwre de ubuntu y lo instalas

    draftSight.deb igual llama al centro de software y lo instalas

    al llamar al prog ya instalado lo primero que pide es la activacion que se obtiene al registrarte en su sitio web.

    al ejecutarlo solo sale la pantalla de presentacion y no se iniicia

    Me gusta

  9. Gerardo, es muy probable que el error sea causado por la instalación de libxcb-render-util0 en tu sistema operativo (que no indicas). Te recomiendo seguir los pasos indicados acá o en este link http://wp.me/p9MkM-mw Si continuas con el error te recomindo que ejecutes el programa desde la línea de comandos y busques el error que ahí te deberá indicar. Si no encontrás la solución te recomiendo que publiques el error en el foro de draftsight http://www.3ds.com/products/draftsight/community/ . Saludos

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s